Actualització de Moodle

Avui per fi m’he decidit a fer l’actualització del moodle d’Aula 3, des de la 1.5.2 a la 1.6.3. I bé, més o menys, ha funcionat…

El primer que he fet ha estat prendre algunes mesures de seguretat:

  1. Fer una còpia de la base de dades. Des de phobos.xtec.cat/mysql2 (identificant-me com a phantom_usuaris:3306) he:
    1. clicat sobre el nom de la base de dades (en negre, adalt, a la banda de l’esquerra).
    2. clicat sobre la pestanya “Exportar” i activar “Selecciona tot”, “Afegir DROP TABLE”, “Enviar” i, llavors, “Executar”
    3. desat la còpia de seguretat al meu ordinador.
  2. Amb el Filezilla, fer una còpia de la carpeta “moodledata”.
  3. Reanomenar la carpeta “moodle” a “moodle153”, per si de cas.

Llavors m’he baixat la versió 1.6.3 del programa des de download.moodle.org i:

  1. l’he descomprimit al meu ordinador
  2. he pujat a phobos, dins la carpeta html, la carpeta “moodle” resultat de la descompressió.
  3. Un cop finalitzada la pujada dels fitxers (aquesta vegada molt més ràpidament perquè ho he fet per FTP normal i no en mode segur) he canviat la carpeta moodledata fora de la carpeta html (abans, per error, estava dins html) i he actualitzat aquest canvi al config.php i…
  4. he anat, amb el navegador, a phobos.xtec.cat/imartin6/moodle i s’ha engegat l’install.php, que ha anat creant/actualitzant les taules i fent la instal·lació. Cal vigilar perquè hi ha un moment que hem de canviar el camí 172.16.1.3 per phobos.xtec.cat (o, si no ho hem fet, canviar-ho després al config.php); i també, és clar, cal baixar i tornar a pujar el config.php. Això sí, ho he fet tot en anglès.

I ha anat fent, fins que ha sortit una pantalla amb Aula 3 que semblava un esborrany. Hi he entrat com a administradora i llavors m’ha dit que havia de fer la migració de les dades (és el missatge d’aquesta entrada). Aquí cal tenir paciència: primer sembla que no faci res però al cap d’una estona surt una barra horitzontal de color verd fins que acaba.

I bé, ja tenia un altre cop el moodle, però sense el tema formal_bally i amb l’entorn en anglès…

M’he baixat els zip amb català i castellà en unicode (ca_utf8 i es_utf8), els he descomprimit i he pujat les carpetes corresponents a moodle/lang (amb el Filezilla). Ho he hagut de fer així perquè el Language import utility no funcionava.

Anuncis
Aquesta entrada s'ha publicat en Uncategorized i etiquetada amb . Afegiu a les adreces d'interès l'enllaç permanent.

Deixa un comentari

Fill in your details below or click an icon to log in:

WordPress.com Logo

Esteu comentant fent servir el compte WordPress.com. Log Out / Canvia )

Twitter picture

Esteu comentant fent servir el compte Twitter. Log Out / Canvia )

Facebook photo

Esteu comentant fent servir el compte Facebook. Log Out / Canvia )

Google+ photo

Esteu comentant fent servir el compte Google+. Log Out / Canvia )

S'està connectant a %s